sunos man page for btopr

Query: btopr

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

btopr(9F)						   Kernel Functions for Drivers 						 btopr(9F)

NAME
btopr - convert size in bytes to size in pages (round up)
SYNOPSIS
#include <sys/ddi.h> unsigned long btopr(unsigned long numbytes);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
numbytes Number of bytes.
DESCRIPTION
btopr() returns the number of memory pages contained in the specified number of bytes memory, rounded up to the next whole page. For exam- ple, if the page size is 2048, then btopr(4096) returns 2, and btopr(4097) returns 3.
RETURN VALUES
The return value is always the number of pages. There are no invalid input values, and therefore no error return values.
CONTEXT
btopr() can be called from user or interrupt context.
SEE ALSO
btop(9F), ddi_btopr(9F), ptob(9F) Writing Device Drivers SunOS 5.10 11 Apr 1991 btopr(9F)
Related Man Pages
btopr(9f) - opensolaris
ptob(9f) - opensolaris
ddi_btopr(9f) - sunos
ddi_ptob(9f) - sunos
ddi_btop(9f) - linux
Similar Topics in the Unix Linux Community
How to convert number to english?
How do I remove or hide SunOS version/release from remote login prompt?
Using awk to remove lines from file that match text
Outputting sequences based on length with sed