osx man page for scsi_poll

Query: scsi_poll

OS: osx

Section: 9f

Links: osx man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_poll(9F)						   Kernel Functions for Drivers 					     scsi_poll(9F)

NAME
scsi_poll - run a polled SCSI command on behalf of a target driver
SYNOPSIS
#include <sys/scsi/scsi.h> int scsi_poll(struct scsi_pkt *pkt);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
pkt Pointer to the scsi_pkt(9S) structure.
DESCRIPTION
scsi_poll() requests the host adapter driver to run a polled command. Unlike scsi_transport(9F) which runs commands asynchronously, scsi_poll() runs commands to completion before returning. If the pkt_time member of pkt is 0, the value of pkt_time is defaulted to SCSI_POLL_TIMEOUT to prevent an indefinite hang of the system.
RETURN VALUES
scsi_poll() returns: 0 command completed successfully. -1 command failed.
CONTEXT
scsi_poll() can be called from user or interrupt level. This function should not be called when the caller is executing timeout(9F) in the context of a thread.
SEE ALSO
makecom(9F), scsi_transport(9F), scsi_pkt(9S) Writing Device Drivers
WARNINGS
Since scsi_poll() runs commands to completion before returning, it may require more time than is desirable when called from interrupt con- text. Therefore, calling scsi_poll from interrupt context is not recommended. SunOS 5.10 30 Aug 1995 scsi_poll(9F)
Related Man Pages
scsi_poll(9f) - sunos
scsi_poll(9f) - linux
scsi_poll(9f) - xfree86
scsi_poll(9f) - bsd
scsi_poll(9f) - posix
Similar Topics in the Unix Linux Community
Cksum read error for directory - Solaris 10