osx man page for ddi_get_instance

Query: ddi_get_instance

OS: osx

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_get_instance(9F)					   Kernel Functions for Drivers 				      ddi_get_instance(9F)

NAME
ddi_get_instance - get device instance number
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_get_instance(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip Pointer to dev_info structure.
DESCRIPTION
ddi_get_instance() returns the instance number of the device corresponding to dip. The system assigns an instance number to every device. Instance numbers for devices attached to the same driver are unique. This pro- vides a way for the system and the driver to uniquely identify one or more devices of the same type. The instance number is derived by the system from different properties for different device types in an implementation specific manner. Once an instance number has been assigned to a device, it will remain the same even across reconfigurations and reboots. Therefore, instance numbers seen by a driver may not appear to be in consecutive order. For example, if device foo0 has been assigned an instance number of 0 and device foo1 has been assigned an instance number of 1, if foo0 is removed, foo1 will continue to be associated with instance number 1 (even though foo1 is now the only device of its type on the system).
RETURN VALUES
ddi_get_instance() returns the instance number of the device corresponding to dip.
CONTEXT
ddi_get_instance()can be called from user or interrupt context.
SEE ALSO
path_to_inst(4) Writing Device Drivers SunOS 5.10 20 Jul 1994 ddi_get_instance(9F)
Related Man Pages
ddi_get_instance(9f) - mojave
ddi_get_instance(9f) - bsd
ddi_get_instance(9f) - v7
ddi_get_instance(9f) - opendarwin
ddi_get_instance(9f) - xfree86
Similar Topics in the Unix Linux Community
Removing devices from ODM
jus a minor issue. please assist if possible.
Need to delete all lines where any line meets a condition