Query: vop_strategy
OS: osx
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
VOP_STRATEGY(9) BSD Kernel Developer's Manual VOP_STRATEGY(9) NAME
VOP_STRATEGY -- read or write a file system buffer SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_STRATEGY(struct vnode *vp, struct buf *bp); DESCRIPTION
The arguments are: vp The vnode that the buffer is for. bp The buffer to be read or written. This call either reads or writes data from a file, depending on the value of bp->b_io.bio_cmd. The call may block. RETURN VALUES
Always zero. Errors should be signalled by setting BIO_ERROR on b_ioflags field in struct buf, and setting b_error to the appropriate errno value. SEE ALSO
vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD
Related Man Pages |
---|
vop_vptocnp(9) - debian |
vop_vptocnp(9) - php |
vop_vptocnp(9) - minix |
vop_vptocnp(9) - linux |
vop_vptocnp(9) - redhat |
Similar Topics in the Unix Linux Community |
---|
AIX Links |
Mac OS X: Based on UNIX - Solid As a Rock |
Installing Dash Shell on OS X Lion |
Syntax error in subtraction in Bash |
Python: Refer a properties file from different location |