osx man page for vop_remove

Query: vop_remove

OS: osx

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_REMOVE(9)						   BSD Kernel Developer's Manual					     VOP_REMOVE(9)

NAME
VOP_REMOVE, VOP_RMDIR -- remove a file or directory SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> int VOP_REMOVE(struct vnode *dvp, struct vnode *vp, struct componentname *cnp); int VOP_RMDIR(struct vnode *dvp, struct vnode *vp, struct componentname *cnp); DESCRIPTION
These entry points remove files and directories respectively. The arguments are: dvp The vnode of the directory. vp The vnode of the file to be removed. cnp Pathname information about the file. LOCKS
Both dvp and vp should be locked on entry and remain locked on return. RETURN VALUES
Zero is returned on success, otherwise an error code is returned. ERRORS
[EPERM] The file is immutable. [ENOTEMPTY] An attempt was made to remove a directory which is not empty. SEE ALSO
vnode(9), VOP_LOOKUP(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD
Related Man Pages
vop_create(9) - debian
vop_create(9) - freebsd
vop_symlink(9) - freebsd
vop_mknod(9) - opensolaris
vop_create(9) - php
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Installing Dash Shell on OS X Lion
At A Glance Coloured Real Time Bargraph Generator...
Shopt -s histappend
A dash to GOTO or a dash from GOTO, that is the question...