osx man page for vop_readlink

Query: vop_readlink

OS: osx

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VOP_READLINK(9) 					   BSD Kernel Developer's Manual					   VOP_READLINK(9)

NAME
VOP_READLINK -- read the target of a symbolic link SYNOPSIS
#include <sys/param.h> #include <sys/vnode.h> #include <sys/uio.h> int VOP_READLINK(struct vnode *vp, struct uio *uio, struct ucred *cred); DESCRIPTION
This reads the target pathname of a symbolic link vp The vnode of the symlink. uio The location of the data to be read or written. cred The credentials of the caller. LOCKS
The vnode should be locked on entry and will still be locked on exit. RETURN VALUES
Zero is returned on success, otherwise an error code is returned. ERRORS
[EIO] A read error occurred while reading the contents of the symlink. SEE ALSO
uiomove(9), vnode(9) AUTHORS
This manual page was written by Doug Rabson. BSD
July 24, 1996 BSD
Related Man Pages
vop_rdwr(9) - freebsd
vop_rdwr(9) - debian
vop_read(9) - debian
vop_rdwr(9) - redhat
vop_write(9) - linux
Similar Topics in the Unix Linux Community
Mac OS X: Based on UNIX - Solid As a Rock
Undeletable file
Shopt -s histappend
A dash to GOTO or a dash from GOTO, that is the question...
Python: Refer a properties file from different location