osx man page for vm_page_wire

Query: vm_page_wire

OS: osx

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VM_PAGE_WIRE(9) 					   BSD Kernel Developer's Manual					   VM_PAGE_WIRE(9)

NAME
vm_page_wire, vm_page_unwire -- wire and unwire pages SYNOPSIS
#include <sys/param.h> #include <vm/vm.h> #include <vm/vm_page.h> void vm_page_wire(vm_page_t m); void vm_page_unwire(vm_page_t m, int activate); DESCRIPTION
The vm_page_wire() function increments the wire count on a page, and removes it from whatever queue it is on. The vm_page_unwire() function releases one of the wirings on the page. When write_count reaches zero the page is placed back onto either the active queue (if activate is non-zero) or onto the inactive queue (if activate is zero). If the page is unmanaged (PG_UNMANAGED is set) then the page is left on PQ_NONE. AUTHORS
This manual page was written by Chad David <davidc@acns.ab.ca>. BSD
July 13, 2001 BSD
Related Man Pages
vm_page_unhold(9) - freebsd
vm_page_free_zero(9) - debian
vm_page_unhold(9) - debian
vm_page_hold(9) - freebsd
vm_page_hold(9) - suse
Similar Topics in the Unix Linux Community
AIX Links
Mac OS X: Based on UNIX - Solid As a Rock
At A Glance Coloured Real Time Bargraph Generator...
Hearing Aid for OSX 10.12.x and greater.
To print diamond asterisk pattern based on inputs