Query: suibyte
OS: osx
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
STORE(9) BSD Kernel Developer's Manual STORE(9)NAMEstore, subyte, suibyte, suiword, sulong, suulong, suword -- store data to user-spaceSYNOPSIS#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> #include <sys/resourcevar.h> int subyte(user_addr_t addr, int byte); int suibyte(user_addr_t addr, int byte); int suiword(user_addr_t addr, int word); int sulong(user_addr_t addr, int64_t longword); int suulong(user_addr_t addr, uint64_t longword); int suword(user_addr_t addr, int word);DESCRIPTIONThe store functions are designed to copy small amounts of data to user-space. The store routines provide the following functionality: subyte() Stores a byte of data to the user-space address addr. suibyte() Stores a byte of data to the user-space address addr. This function is safe to call during an interrupt context. suiword() Stores a word of data to the user-space address addr. This function is safe to call during an interrupt context. sulong() Stores a long word of data to the user-space address addr. suulong() Stores a unsigned long word of data to the user-space address addr. suword() Stores a word of data to the user-space address addr.RETURN VALUESThe store functions return 0 on success or -1 on failure.SEE ALSOcopy(9), fetch(9)BSDDecember 16, 2004 BSD
Related Man Pages |
---|
subyte(9) - mojave |
suulong(9) - mojave |
store(9) - osx |
suiword(9) - osx |
suulong(9) - osx |