opensolaris man page for hook_nic_event

Query: hook_nic_event

OS: opensolaris

Section: 9s

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

hook_nic_event(9S)					    Data Structures for Drivers 					hook_nic_event(9S)

NAME
hook_nic_event - data structure describing events related to network interfaces
SYNOPSIS
#include <sys/neti.h> #include <sys/hook.h> #include <sys/hook_event.h>
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
The hook_nic_event structure contains fields that relate to an event that has occurred and belongs to a network interface. This structure is passed through to callbacks for NE_PLUMB, NE_UNPLUMB, NE_UP, NE_DOWN and NE_ADDRESS_CHANGE events. A callback may not alter any of the fields in this structure.
STRUCTURE MEMBERS
net_data_t hne_family; phy_if_t pkt_private; lif_if_t hne_lif; nic_event_t hne_event; nic_event_data_t hne_data; size_t hne_datalen; The following fields are set for each event: hne_family A valid reference for the network protocol that owns this network interface and can be in calls to other netinfo(9F) func- tions. hne_nic The physical interface to which an event belongs. hne_event A value that indicates the respective event. The current list of available events is: NE_PLUMB an interface has just been created. NE_UNPLUMB an interface has just been destroyed and no more events should be received for it. NE_UP an interface has changed the state to "up" and may now generate packet events. NE_DOWN an interface has changed the state to "down" and will no longer generate packet events. NE_ADDRESS_CHANGE an address on an interface has changed. hne_lif refers to the logical interface for which the change is occurring, hne_data is a pointer to a sockaddr structure that is hne_datalen bytes long and contains the new network address.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
netinfo(9F) SunOS 5.11 1 May 2008 hook_nic_event(9S)
Related Man Pages
hook_pkt_event(9s) - opensolaris
net_getifname(9f) - opensolaris
net_getlifaddr(9f) - opensolaris
net_lifgetnext(9f) - opensolaris
net_routeto(9f) - opensolaris
Similar Topics in the Unix Linux Community
Replacement for netinfo
On messages and events
On latency in event processing network
On single application vs. general event processing software - the network and system
Route new network interface Solaris 8