opensolaris man page for uwritec

Query: uwritec

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

uwritec(9F)						   Kernel Functions for Drivers 					       uwritec(9F)

NAME
uwritec - remove a character from a uio structure
SYNOPSIS
#include <sys/uio.h> int uwritec(uio_t *uio_p);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI)
PARAMETERS
uio_p Pointer to the uio(9S) structure
DESCRIPTION
The uwritec() function returns a character from the uio structure pointed to by uio_p and updates the uio structure. See uiomove(9F).
RETURN VALUES
The next character for processing is returned on success, and -1 is returned if uio is empty or if there is an error.
CONTEXT
The uwritec() function can be called from user, interrupt, or kernel context.
SEE ALSO
uiomove(9F), ureadc(9F), iovec(9S), uio(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 uwritec(9F)
Related Man Pages
uio(9s) - opensolaris
uwritec(9f) - opensolaris
uio(3head) - sunos
ureadc(9f) - sunos
uio.h(3head) - sunos
Similar Topics in the Unix Linux Community
How to learn UNIX
Study UNIX Kernel
Change directory for core file
Grep the 'not running' jobs and will send the update in mail with its name(job)
What's legal and what's not?