opensolaris man page for usb_pipe_get_max_bulk_transfer_size

Query: usb_pipe_get_max_bulk_transfer_size

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

usb_pipe_get_max_bulk_transfer_size(9F) 		   Kernel Functions for Drivers 		   usb_pipe_get_max_bulk_transfer_size(9F)

NAME
usb_pipe_get_max_bulk_transfer_size - Get maximum bulk transfer size
SYNOPSIS
#include <sys/usb/usba.h> int usb_pipe_get_max_bulk_transfer_size(dev_info_t dip, size_t *size);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
dip Pointer to the device's dev_info structure. size Returns the bulk transfer size.
DESCRIPTION
The usb_pipe_get_max_bulk_transfer_size() function returns the maximum data transfer size in bytes that the host controller driver can sup- port per bulk request. This information can be used to limit or break down larger requests to manageable sizes.
RETURN VALUES
USB_SUCCESS Size is returned in size argument. USB_INVALID_ARGS dip and/or size argument is NULL. USB_FAILURE Size could not be returned. Zero is returned in size arg.
CONTEXT
May be called from user, kernel or interrupt context.
EXAMPLES
int xxx_attach(dev_info_t *dip, int command) { ... usb_pipe_get_max_bulk_transfer_size(dip, &state>max_xfer_size); ... } void xxx_minphys(struct buf bp) { ... if (bp->b_bcount > state->max_xfer_size) { bp->b_bcount = state->max_xfer_size; } ... }
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), usb_pipe_bulk_xfer(9F), usb_alloc_request(9F), usb_bulk_request(9S) SunOS 5.11 5 Jan 2004 usb_pipe_get_max_bulk_transfer_size(9F)
Related Man Pages
usb_alloc_ctrl_req(9f) - opensolaris
usb_get_max_pkts_per_isoc_request(9f) - opensolaris
usb_alloc_bulk_req(9f) - opensolaris
usb_pipe_get_max_bulk_transfer_size(9f) - sunos
usb_free_bulk_req(9f) - opensolaris
Similar Topics in the Unix Linux Community
How to read specific lines in a bulk file using C file Programming
Database Size