opensolaris man page for stoi

Query: stoi

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

stoi(9F)						   Kernel Functions for Drivers 						  stoi(9F)

NAME
stoi, numtos - convert between an integer and a decimal string
SYNOPSIS
#include <sys/ddi.h> int stoi(char **str); void numtos(unsigned long num, char *s);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
str Pointer to a character string to be converted. num Decimal number to be converted to a character string. s Character buffer to hold converted decimal number.
DESCRIPTION
stoi() The stoi() function returns the integer value of a string of decimal numeric characters beginning at **str. No overflow checking is done. *str is updated to point at the last character examined. numtos() The numtos() function converts a long into a null-terminated character string. No bounds checking is done. The caller must ensure there is enough space to hold the result.
RETURN VALUES
The stoi() function returns the integer value of the string str.
CONTEXT
The stoi() function can be called from user, interrupt, or kernel context.
SEE ALSO
Writing Device Drivers
NOTES
The stoi() function handles only positive integers; it does not handle leading minus signs. SunOS 5.11 16 Jan 2006 stoi(9F)
Related Man Pages
ddi_strtol(9f) - sunos
kstat_named_init(9f) - sunos
kstat_named_setstr(9f) - sunos
ddi_strtoll(9f) - opensolaris
ddi_strtoul(9f) - opensolaris
Similar Topics in the Unix Linux Community
simple question on string concat
string checking
Condition for decimal numbers
PERL : Use of a variable in a tr
Replace Special Character With Next Present Byte