Query: scsi_hba_probe
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
scsi_hba_probe(9F) Kernel Functions for Drivers scsi_hba_probe(9F)NAMEscsi_hba_probe - default SCSI HBA probe functionSYNOPSIS#include <sys/scsi/scsi.h> int scsi_hba_probe(struct scsi_device *sd, int(*waitfunc)(void));INTERFACE LEVELSolaris architecture specific (Solaris DDI).PARAMETERSsd Pointer to a scsi_device(9S) structure describing the target. waitfunc NULL_FUNC or SLEEP_FUNC.DESCRIPTIONscsi_hba_probe() is a function providing the semantics of scsi_probe(9F). An HBA driver may call scsi_hba_probe() from its tran_tgt_probe(9E) entry point, to probe for the existence of a target on the SCSI bus, or the HBA may set tran_tgt_probe(9E) to point to scsi_hba_probe directly.RETURN VALUESSee scsi_probe(9F) for the return values from scsi_hba_probe().CONTEXTscsi_hba_probe() should only be called from the HBA's tran_tgt_probe(9E) entry point.SEE ALSOtran_tgt_probe(9E), scsi_probe(9F), scsi_device(9S) Writing Device Drivers SunOS 5.11 30 Aug 1995 scsi_hba_probe(9F)