Query: scsi_find_sense_descr
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
scsi_find_sense_descr(9F) Kernel Functions for Drivers scsi_find_sense_descr(9F)NAMEscsi_find_sense_descr - find descriptor in SCSI sense dataSYNOPSIS#include <sys/scsi/scsi.h> uint8_t *scsi_find_sense_descr(uint8_t *sense_buffer, int sense_buf_len, int req_descr_type);INTERFACE LEVELSolaris DDI specific (Solaris DDI).PARAMETERSsense_buffer Pointer to a buffer containing SCSI descriptor sense data. The data is expected in wire format starting at the response code. sense_buf_len Integer that contains the length of sense buffer in bytes. req_descr_type Integer that contains the descriptor type value for the desired sense descriptor.DESCRIPTIONThe scsi_find_sense_descr() function is used to obtain a pointer to a specific descriptor type, specified by req_descr_type, within a descriptor sense buffer. Before returning the pointer, scsi_find_sense_descr() verifies that the entire descriptor is present based on the length provided in sense_buf_len. Any value for req_descr_type can be requested. The following descriptor types are already defined: #define DESCR_INFORMATION 0x00 #define DESCR_COMMAND_SPECIFIC 0x01 #define DESCR_SENSE_KEY_SPECIFIC 0x02 #define DESCR_FRU 0x03 #define DESCR_STREAM_COMMANDS 0x04 #define DESCR_BLOCK_COMMANDS 0x05 #define DESCR_OSD_OID 0x06 #define DESCR_OSD_RESP_INTEGRITY 0x07 #define DESCR_OSD_ATTR_ID 0x08 Drivers should use scsi_validate_sense(9F) to ensure that the sense buffer contains valid descriptor sense data.RETURN VALUESThe scsi_find_sense_descr() function returns a pointer to a sense descriptor of the requested type if a descriptor of that type exists. If no such descriptor exists, scsi_find_sense_descr() returns NULL.CONTEXTThe scsi_find_sense_descr() function can be called from user or interrupt context.SEE ALSOscsi_ext_sense_fields(9F), scsi_sense_asc(9F), scsi_sense_ascq(9F), scsi_sense_cmdspecific_uint64(9F), scsi_sense_info_uint64(9F), scsi_sense_key(9F), scsi_validate_sense(9F) SunOS 5.11 30 Jun 2006 scsi_find_sense_descr(9F)
Related Man Pages |
---|
scsi_sense_info_uint64(9f) - opensolaris |
scsi_arq_status(9s) - sunos |
scsi_sense_asc(9f) - opensolaris |
scsi_sense_ascq(9f) - opensolaris |
scsi_arq_status(9s) - centos |
Similar Topics in the Unix Linux Community |
---|
file pointer |
Difference between file descriptor and file pointer |
error:'MSG_R' undeclared (first use in this function) under Solaris |