opensolaris man page for scsi_abort

Query: scsi_abort

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_abort(9F)						   Kernel Functions for Drivers 					    scsi_abort(9F)

NAME
scsi_abort - abort a SCSI command
SYNOPSIS
#include <sys/scsi/scsi.h> intscsi_abort(struct scsi_address *ap, struct scsi_pkt *pkt);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
ap Pointer to a scsi_address structure. pkt Pointer to a scsi_pkt(9S) structure.
DESCRIPTION
The scsi_abort() function terminates a command that has been transported to the host adapter driver. A NULL pkt causes all outstanding packets to be aborted. On a successful abort, the pkt_reason is set to CMD_ABORTED and pkt_statistics is OR'ed with STAT_ABORTED.
RETURN VALUES
The scsi_abort() function returns: 1 on success. 0 on failure.
CONTEXT
The scsi_abort() function can be called from user, interrupt, or kernel context.
EXAMPLES
Example 1 Terminating a command. if (scsi_abort(&devp->sd_address, pkt) == 0) { (void) scsi_reset(&devp->sd_address, RESET_ALL); }
SEE ALSO
tran_abort(9E), scsi_reset(9F), scsi_pkt(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 scsi_abort(9F)
Related Man Pages
scsi_abort(9f) - osx
scsi_abort(9f) - hpux
scsi_abort(9f) - linux
scsi_abort(9f) - xfree86
scsi_abort(9f) - posix
Similar Topics in the Unix Linux Community
What does this mean?
PHP Man Pages Now Available (Over 10,000)
Change directory for core file
Identify problem with while getopts
Solaris 10 - password complexity not working