opensolaris man page for qunbufcall

Query: qunbufcall

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

qunbufcall(9F)						   Kernel Functions for Drivers 					    qunbufcall(9F)

NAME
qunbufcall - cancel a pending qbufcall request
SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> void qunbufcall(queue_t *q, bufcall_id_t id);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
q Pointer to STREAMS queue_t structure. id Identifier returned from qbufcall(9F).
DESCRIPTION
The qunbufcall() function cancels a pending qbufcall() request. The argument id is a non-zero identifier of the request to be cancelled. id is returned from the qbufcall() function used to issue the cancel request. The qunbufcall() function is tailored to be used with the enhanced STREAMS framework interface which is based on the concept of perimeters. (See mt-streams(9F).) qunbufcall() returns when the bufcall has been cancelled or finished executing. The bufcall will be cancelled even if it is blocked at the perimeters associated with the queue. All outstanding timeouts and bufcalls must be cancelled before a driver close routine can block and before the close routine calls qprocsoff(9F).
CONTEXT
The qunbufcall() function can be called from user, interrupt, or kernel context.
SEE ALSO
mt-streams(9F), qbufcall(9F), qtimeout(9F), quntimeout(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 qunbufcall(9F)
Related Man Pages
qunbufcall(9f) - sunos
qbufcall(9f) - centos
qbufcall(9f) - minix
qbufcall(9f) - php
qunbufcall(9f) - osx
Similar Topics in the Unix Linux Community
Trying to block signal
solaris zones vs container..
Grep the 'not running' jobs and will send the update in mail with its name(job)
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
What's legal and what's not?