opensolaris man page for qsize

Query: qsize

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

qsize(9F)						   Kernel Functions for Drivers 						 qsize(9F)

NAME
qsize - find the number of messages on a queue
SYNOPSIS
#include <sys/stream.h> int qsize(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Queue to be evaluated.
DESCRIPTION
The qsize() function evaluates the queue q and returns the number of messages it contains.
RETURN VALUES
If there are no message on the queue, qsize() returns 0. Otherwise, it returns the integer representing the number of messages on the queue.
CONTEXT
The qsize() function can be called from user, interrupt, or kernel context.
SEE ALSO
Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 qsize(9F)
Related Man Pages
rd(9f) - opensolaris
wr(9f) - opensolaris
canput(9f) - sunos
canput(9f) - centos
canput(9f) - php
Similar Topics in the Unix Linux Community
ioctl() system call on Linux-i386
why printf() function don't go work?
Thread parameter in ANSI C makes a segmentation fault
AIX 6.1 reach the threshold of stream(no -a|grep strthresh)
Wait process holding CPU