opensolaris man page for pollwakeup

Query: pollwakeup

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

pollwakeup(9F)						   Kernel Functions for Drivers 					    pollwakeup(9F)

NAME
pollwakeup - inform a process that an event has occurred
SYNOPSIS
#include <sys/poll.h> void pollwakeup(struct pollhead *php, short event);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
php Pointer to a pollhead structure. event Event to notify the process about.
DESCRIPTION
The pollwakeup() function wakes a process waiting on the occurrence of an event. It should be called from a driver for each occurrence of an event. The pollhead structure will usually be associated with the driver's private data structure associated with the particular minor device where the event has occurred. See chpoll(9E) and poll(2) for more detail.
CONTEXT
The pollwakeup() function can be called from user, interrupt, or kernel context.
SEE ALSO
poll(2), chpoll(9E) Writing Device Drivers
NOTES
Driver defined locks should not be held across calls to this function. SunOS 5.11 16 Jan 2006 pollwakeup(9F)
Related Man Pages
chpoll(9e) - opensolaris
pollwakeup(9f) - opensolaris
pollwakeup(9f) - debian
pollwakeup(9f) - linux
pollwakeup(9f) - osf1
Similar Topics in the Unix Linux Community
EPTS: Proposed Event Processing Definitions, September 20, 2006