opensolaris man page for pci_config_setup

Query: pci_config_setup

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

pci_config_setup(9F)					   Kernel Functions for Drivers 				      pci_config_setup(9F)

NAME
pci_config_setup, pci_config_teardown - setup or tear down the resources for enabling accesses to the PCI Local Bus Configuration space
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int pci_config_setup(dev_info_t *dip, ddi_acc_handle_t *handle); void pci_config_teardown(ddi_acc_handle_t *handle);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip Pointer to the device's dev_info structure. handle Pointer to a data access handle.
DESCRIPTION
pci_config_setup() sets up the necessary resources for enabling subsequent data accesses to the PCI Local Bus Configuration space. pci_config_teardown() reclaims and removes those resources represented by the data access handle returned from pci_config_setup().
RETURN VALUES
pci_config_setup() returns: DDI_SUCCESS Successfully setup the resources. DDI_FAILURE Unable to allocate resources for setup.
CONTEXT
pci_config_setup() must be called from user or kernel context. pci_config_teardown() can be called from any context.
NOTES
These functions are specific to PCI bus device drivers. For drivers using these functions, a single source to support devices with multi- ple bus versions may not be easy to maintain.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI Local Bus | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5) IEEE 1275 PCI Bus Binding SunOS 5.11 1 Jan 1997 pci_config_setup(9F)
Related Man Pages
pci_config_get8(9f) - sunos
pci_config_setup(9f) - opensolaris
pci_config_getb(9f) - sunos
pci_config_getl(9f) - sunos
pci_config_teardown(9f) - sunos
Similar Topics in the Unix Linux Community
Any EVA admin's out there?
To setup chrooting ftp