Query: net_phygetnext
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
net_phygetnext(9F) Kernel Functions for Drivers net_phygetnext(9F)NAMEnet_phygetnext - search through the current list of network interfacesSYNOPSIS#include <sys/neti.h> phy_if_t net_phygetnext(const net_data_t net, const phy_if_t ifp);INTERFACE LEVELSolaris DDI specific (Solaris DDI).PARAMETERSnet value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to this function or net_phylookup(9F).DESCRIPTIONThe net_phygetnext() function searches through all of the network interfaces that a network protocol "owns". To start searching through all of the interfaces owned by a protocol, a value of 0 should be passed through as the value of ifp. When 0 is returned by this function, the last of the interfaces owned by this protocol has been reached. When called successfully, the value returned represents a network interface that exists, at the time of the call, within the scope of the network interface. This value is only guaranteed to be unique for a name within the scope of the network protocol.EXAMPLESnet_data_t net; phy_if_t ifp; char buffer[32]; net = net_protocol_lookup("inet"); if (net != NULL) { for (ifp = net_phygetnext(net, 0); ifp != 0; ifp = net_phygetnext(net, ifp)) { /* Do something with ifp */ if (net_getifname(net, ifp, buffer, sizeof(buffer) >= 0) printf("Interface %s0, buffer); } }RETURN VALUESThe net_phygetnext() function returns -1 if it is not supported by the network protocol or 0 if an attempt to go beyond the last network interface is made. Otherwise, it returns a value representing a network interface.CONTEXTThe net_phygetnext() function may be called from user, kernel, or interrupt context.ATTRIBUTESSee attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+SEE ALSOnet_phylookup(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_phygetnext(9F)
Related Man Pages |
---|
net_getifname(9f) - opensolaris |
drbr_enqueue(9) - freebsd |
net_protocol_lookup(9f) - opensolaris |
net_phygetnext(9f) - opensolaris |
net_routeto(9f) - opensolaris |
Similar Topics in the Unix Linux Community |
---|
Route new network interface Solaris 8 |
retrieving network interface list |
want know about network protocol testing |
/etc/network/interfaces |
Access to network interface (Mac-network) |