opensolaris man page for net_getmtu

Query: net_getmtu

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: forum home   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

net_getmtu(9F)						   Kernel Functions for Drivers 					    net_getmtu(9F)

NAME
net_getmtu - determine the MTU of a given network interface
SYNOPSIS
#include <sys/neti.h> int net_getmtu(const net_data_t net, const phy_if_t ifp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F).
DESCRIPTION
The net_getmtu() function receives information about the current MTU of a network interface. The value returned from this function call should not be cached as the MTU of a network interface since it is not guaranteed to be constant.
RETURN VALUES
The net_getmtu() function returns -1 if the network protocol does not support this feature and otherwise returns the current MTU of the network interface.
CONTEXT
The net_getmtu() function may be called from user, kernel, or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F) SunOS 5.11 1 May 2008 net_getmtu(9F)