opensolaris man page for net_getlifaddr

Query: net_getlifaddr

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

net_getlifaddr(9F)					   Kernel Functions for Drivers 					net_getlifaddr(9F)

NAME
net_getlifaddr - determine a network address for a given interface
SYNOPSIS
#include <sys/neti.h> int net_getlifaddr(const net_data_t net, const phy_if_t ifp, const net_if_t lif, int const type, struct sockaddr* storage);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F), indicating which network interface the infor- mation should be returned from. lif indicates the logical interface from which to fetch the address. type indicates what type of address should be returned. See below for more details on this field. storage pointer to an area of memory to store the address data.
DESCRIPTION
The net_getlifaddr() function retrieves the address information for each logical interface. Each call to net_getlifaddr() requires that the caller pass a pointer to an array of address information types to retrieve, and an accompanying pointer to an array of pointers to struct sockaddr structures to which to copy the address information. See net_lifgetnext(9F) for an example on how to use this function. Each member of the address type array should be one of the values listed here. NA_ADDRESS Return the network address associated with the logical interface (lif) that belongs to the network interface (ifp). NA_PEER Return the address assigned to the remote host for point to point network interfaces for the given network/logical inter- face. NA_BROADCAST Return the broadcast address assigned to the given network/logical interface for network interfaces that support broadcast packets. NA_NETMASK Return the netmask associated with the given network/logical interface for network interfaces that support broadcast pack- ets.
RETURN VALUES
The net_getlifaddr() function returns: -1 The network protocol does not support this function. 0 Successful completion. 1 Unsuccessful.
CONTEXT
The net_getifaddr() function may be called from user, kernel, or interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
net_lifgetnext(9F), net_phylookup(9F), net_phygetnext(9F)net_protocol_lookup(9F) SunOS 5.11 13 Oct 2008 net_getlifaddr(9F)
Related Man Pages
net_lifgetnext(9f) - opensolaris
net_phygetnext(9f) - opensolaris
freeifaddrs(3) - netbsd
getifaddrs(3) - netbsd
getifaddrs(3) - freebsd
Similar Topics in the Unix Linux Community
broadcast address
Help with IBM 550 and HMC settings
Route new network interface Solaris 8
bring up/down numerous interfaces
Shell script to give broadcast and network address