opensolaris man page for ldi_aread

Query: ldi_aread

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_aread(9F)						   Kernel Functions for Drivers 					     ldi_aread(9F)

NAME
ldi_aread, ldi_awrite - Issue an asynchronous read or write request to a device
SYNOPSIS
#include <sys/sunldi.h> int ldi_aread(ldi_handle_t lh, struct aio_req *aio_reqp, cred_t *cr); int ldi_awrite(ldi_handle_t lh, struct aio_req *aio_reqp, cred_t *cr);
PARAMETERS
lh Layered handle. cr Pointer to a credential structure. aio_reqp Pointer to the aio_req(9S) structure that describes where the data is to be stored or obtained from.
DESCRIPTION
The ldi_awrite() function passes an asynchronous write request to a device entry point specified by the layered handle. This operation is supported for block and character devices. The ldi_aread() function passes an asynchronous read request to a device entry point specified by the layered handle. This operation is supported for block and character devices.
RETURN VALUES
The ldi_awrite() and ldi_aread() functions return 0 upon success. If a failure occurs before the request is passed on to the device, the possible return values are shown below. Otherwise any other error number may be returned by the device. EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device.
CONTEXT
These functions may be called from user context. SunOS 5.11 3 June 2003 ldi_aread(9F)
Related Man Pages
ldi_aread(9f) - sunos
ldi_awrite(9f) - sunos
ldi_read(9f) - opensolaris
ldi_write(9f) - opensolaris
awrite(9e) - php
Similar Topics in the Unix Linux Community
solaris zones vs container..
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
What's legal and what's not?
What is good?
Shopt -s histappend