opensolaris man page for kstat_install

Query: kstat_install

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

kstat_install(9F)					   Kernel Functions for Drivers 					 kstat_install(9F)

NAME
kstat_install - add a fully initialized kstat to the system
SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> void kstat_install(kstat_t *ksp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
ksp Pointer to a fully initialized kstat(9S) structure.
DESCRIPTION
kstat_install() is used in conjunction with kstat_create(9F) to allocate and initialize a kstat(9S) structure. After a successful call to kstat_create() the driver must perform any necessary initialization of the data section (such as setting the name fields in a kstat of type KSTAT_TYPE_NAMED). Virtual kstats must have the ks_data field set at this time. The provider may also set the ks_update, ks_private, and ks_lock fields if necessary. Once the kstat is completely initialized, kstat_install is used to make the kstat accessible to the outside world.
RETURN VALUES
None.
CONTEXT
kstat_install() can be called from user or kernel context.
EXAMPLES
Example 1 Allocating and Initializing a kstat Structure The method for allocating and initializing a kstat structure is generally as follows: kstat_t *ksp; ksp = kstat_create(module, instance, name, class, type, ndata, flags); if (ksp) { /* ... provider initialization, if necessary */ kstat_install(ksp); }
SEE ALSO
kstat_create(9F), kstat_delete(9F), kstat_named_init(9F), kstat(9S) Writing Device Drivers SunOS 5.11 26 May 1994 kstat_install(9F)
Related Man Pages
kstat_write(3kstat) - sunos
kstat_data_lookup(3kstat) - opensolaris
net_kstat_create(9f) - opensolaris
kstat_create(9f) - opensolaris
ks_snapshot(9e) - opensolaris
Similar Topics in the Unix Linux Community
kstat - format of output data?
where can i get the variable tree for kvm &amp; kstat
kstat on T5220
Question on kstat output
Does PowerSHell have *stat command analogs?