opensolaris man page for getminor

Query: getminor

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

getminor(9F)						   Kernel Functions for Drivers 					      getminor(9F)

NAME
getminor - get minor device number
SYNOPSIS
#include <sys/types.h> #include <sys/mkdev.h> #include <sys/ddi.h> minor_t getminor(dev_t dev);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
dev Device number.
DESCRIPTION
The getminor() function extracts the minor number from a device number.
RETURN VALUES
The minor number.
CONTEXT
The getminor() function can be called from user, interrupt, or kernel context.
EXAMPLES
See the getmajor(9F) manual page for an example of how to use getminor().
SEE ALSO
getmajor(9F), makedevice(9F) Writing Device Drivers
WARNINGS
No validity checking is performed. If dev is invalid, an invalid number is returned. SunOS 5.11 16 Jan 2006 getminor(9F)
Related Man Pages
getminor(9f) - mojave
getmajor(9f) - centos
getmajor(9f) - minix
getmajor(9f) - v7
getmajor(9f) - ultrix
Similar Topics in the Unix Linux Community
Where can I find Linux functions corresponding to the Solaris DDI?