opensolaris man page for geterror

Query: geterror

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

geterror(9F)						   Kernel Functions for Drivers 					      geterror(9F)

NAME
geterror - return I/O error
SYNOPSIS
#include <sys/types.h> #include <sys/buf.h> #include <sys/ddi.h> int geterror(struct buf *bp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
bp Pointer to a buf(9S) structure.
DESCRIPTION
The geterror() function returns the error number from the error field of the buffer header structure.
RETURN VALUES
An error number indicating the error condition of the I/O request is returned. If the I/O request completes successfully, 0 is returned.
CONTEXT
The geterror() function can be called from user, interrupt, or kernel context.
SEE ALSO
buf(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 geterror(9F)
Related Man Pages
biowait(9f) - opensolaris
bioerror(9f) - centos
bioerror(9f) - suse
bioerror(9f) - redhat
bioerror(9f) - osf1
Similar Topics in the Unix Linux Community
Java program calling a UNIX command
Expat install
Oracle (11gr2) calling unix commands (aix)
Incompatiblity of the code due to CC compiler version mismatch.
Please Help Test New Registration Page