opensolaris man page for drv_hztousec

Query: drv_hztousec

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

drv_hztousec(9F)					   Kernel Functions for Drivers 					  drv_hztousec(9F)

NAME
drv_hztousec - convert clock ticks to microseconds
SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> clock_t drv_hztousec(clock_t hertz);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
hertz The number of clock ticks to convert.
DESCRIPTION
The drv_hztousec() function converts into microseconds the time expressed by hertz, which is in system clock ticks. The kernel variable lbolt, whose value should be retrieved by calling ddi_get_lbolt(9F), is the length of time the system has been up since boot and is expressed in clock ticks. Drivers often use the value of lbolt before and after an I/O request to measure the amount of time it took the device to process the request. The drv_hztousec() function can be used by the driver to convert the reading from clock ticks to a known unit of time.
RETURN VALUES
The number of microseconds equivalent to the hertz parameter. No error value is returned. If the microsecond equivalent to hertz is too large to be represented as a clock_t, then the maximum clock_t value will be returned.
CONTEXT
The drv_hztousec() function can be called from user, interrupt, or kernel context.
SEE ALSO
ddi_get_lbolt(9F), drv_usectohz(9F), drv_usecwait(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 drv_hztousec(9F)
Related Man Pages
drv_hztousec(9f) - opensolaris
drv_hztousec(9f) - debian
drv_hztousec(9f) - xfree86
drv_hztousec(9f) - posix
drv_hztousec(9f) - minix
Similar Topics in the Unix Linux Community
clock() function
kernel error!