opensolaris man page for devmap_set_ctx_timeout

Query: devmap_set_ctx_timeout

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

devmap_set_ctx_timeout(9F)				   Kernel Functions for Drivers 				devmap_set_ctx_timeout(9F)

NAME
devmap_set_ctx_timeout - set the timeout value for the context management callback
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void devmap_set_ctx_timeout(devmap_cookie_t dhp, clock_t ticks);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dhp An opaque mapping handle that the system uses to describe the mapping. ticks Number of clock ticks to wait between successive calls to the context management callback function.
DESCRIPTION
The devmap_set_ctx_timeout() function specifies the time interval for the system to wait between successive calls to the driver's context management callback function, devmap_contextmgt(9E). Device drivers typically call devmap_set_ctx_timeout() in the devmap_map(9E) routine. If the drivers do not call devmap_set_ctx_timeout() to set the timeout value, the default timeout value of 0 will result in no delay between successive calls to the driver's devmap_con- textmgt(9E) callback function.
CONTEXT
The devmap_set_ctx_timeout() function can be called from user, interrupt, or kernel context.
SEE ALSO
devmap_contextmgt(9E), devmap_map(9E), timeout(9F) SunOS 5.11 16 Jan 2006 devmap_set_ctx_timeout(9F)
Related Man Pages
devmap_contextmgt(9e) - opensolaris
devmap_contextmgt(9e) - sunos
devmap_set_ctx_timeout(9f) - sunos
devmap_set_ctx_timeout(9f) - opensolaris
devmap_do_ctxmgt(9f) - centos
Similar Topics in the Unix Linux Community
Trying to block signal
How to learn UNIX
What does this mean?
Change directory for core file
Grep the 'not running' jobs and will send the update in mail with its name(job)