opensolaris man page for ddi_periodic_delete

Query: ddi_periodic_delete

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_periodic_delete(9F) 				   Kernel Functions for Drivers 				   ddi_periodic_delete(9F)

NAME
ddi_periodic_delete - cancel nanosecond periodic timeout requests
SYNOPSIS
#include <sys/dditypes.h> #include <sys/sunddi.h> void ddi_periodic_delete(ddi_periodic_t req)
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
req ddi_periodic_t opaque value returned by ddi_periodic_add(9F).
DESCRIPTION
The ddi_periodic_delete() function cancels the ddi_periodic_add(9F) request that was previously issued. As with untimeout(9F), calling ddi_periodic_delete() against a periodic timeout request which is either running on another CPU, or has already been canceled causes no problems. Unlike untimeout(9F), there are no restrictions on the lock which might be held across the call to ddi_periodic_delete().
CONTEXT
The ddi_periodic_delete() function may be called from user or kernel context.
EXAMPLES
Example 1 Cancelling a timeout request In the following example, the device driver cancels the timeout request by calling ddi_periodic_delete() against the request that was pre- viously issued. /* * Stop the periodic timer */ static void stop_periodic_timer(struct my_state *statep) { ddi_periodic_delete(statep->periodic_id); mutex_destory(&statep->lock); } static void start_periodic_timer(struct my_state *statep) { hrtime_t interval = CHECK_INTERVAL; mutex_init(&statep->lock, NULL, MUTEX_DRIVER, (void *)DDI_IPL_0); /* * Register my_callback which is invoked periodically * in CHECK_INTERVAL in kernel context. */ statep->periodic_id = ddi_periodic_add(my_periodic_func, statep, interval, DDI_IPL_0); } static void my_periodic_func(void *arg) { /* * This handler is invoked periodically. */ struct my_state *statep = (struct my_state *)arg; mutex_enter(&statep->lock); if (load_unbalanced(statep)) { balance_tasks(statep); } mutex_exit(&statep->lock); }
SEE ALSO
cv_timedwait(9F), ddi_intr_get_pri(9F), ddi_periodic_add(9F), delay(9F), drv_usectohz(9F), qtimeout(9F), quntimeout(9F), timeout(9F), untimeout(9F) SunOS 5.11 2 Oct 2007 ddi_periodic_delete(9F)
Related Man Pages
ddi_periodic_add(9f) - opensolaris
ddi_periodic_delete(9f) - opensolaris
qtimeout(9f) - debian
qtimeout(9f) - php
qtimeout(9f) - opendarwin
Similar Topics in the Unix Linux Community
Change directory for core file
Grep the 'not running' jobs and will send the update in mail with its name(job)
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
What's legal and what's not?
%memused is high