opensolaris man page for ddi_intr_hilevel

Query: ddi_intr_hilevel

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_intr_hilevel(9F)					   Kernel Functions for Drivers 				      ddi_intr_hilevel(9F)

NAME
ddi_intr_hilevel - indicate interrupt handler type
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_hilevel(dev_info_t *dip, uint_t inumber);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the new interrupt interfaces referenced in Intro(9F). Refer to Writing Device Drivers for more information.
PARAMETERS
dip Pointer to dev_info structure. inumber Interrupt number.
DESCRIPTION
The ddi_intr_hilevel() function returns non-zero if the specified interrupt is a "high level" interrupt. High level interrupts must be handled without using system services that manipulate thread or process states, because these interrupts are not blocked by the scheduler. In addition, high level interrupt handlers must take care to do a minimum of work because they are not preemptable. A typical high level interrupt handler would put data into a circular buffer and schedule a soft interrupt by calling ddi_trigger_soft- intr(). The circular buffer could be protected by using a mutex that was properly initialized for the interrupt handler. The ddi_intr_hilevel() function can be used before calling ddi_add_intr() to decide which type of interrupt handler should be used. Most device drivers are designed with the knowledge that the devices they support will always generate low level interrupts, however some devices, for example those using SBus or VME bus level 6 or 7 interrupts must use this test because on some machines those interrupts are high level (above the scheduler level) and on other machines they are not.
RETURN VALUES
non-zero indicates a high-level interrupt.
CONTEXT
These functions can be called from useruser, interrupt, or kernel context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+
SEE ALSO
ddi_add_intr(9F), Intro(9F), mutex(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_intr_hilevel(9F)
Related Man Pages
ddi_add_intr(9f) - opensolaris
ddi_trigger_softintr(9f) - opensolaris
ddi_add_softintr(9f) - opensolaris
ddi_get_soft_iblock_cookie(9f) - opensolaris
ddi_remove_softintr(9f) - opensolaris
Similar Topics in the Unix Linux Community
Quality Best High Fake Passports,ID,Drivers License for Sale