opensolaris man page for ddi_intr_get_hilevel_pri

Query: ddi_intr_get_hilevel_pri

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_intr_get_hilevel_pri(9F)				   Kernel Functions for Drivers 			      ddi_intr_get_hilevel_pri(9F)

NAME
ddi_intr_get_hilevel_pri - get minimum priority level for a high-level interrupt
SYNOPSIS
#include <sys/types.h> #include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_get_hilevel_pri(void);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
Upon a successful return, the ddi_intr_get_hilevel_pri() function returns the minimum priority level for a high-level interrupt. The return priority value can be used to compare to other priority values, such as those returned from ddi_intr_get_pri(9F), to determine if a given interrupt priority is a high-level interrupt. High-level interrupts must be handled without using system services that manipulate thread or process states, because such interrupts are not blocked by the scheduler. In addition, high-level interrupt handlers must take care to do a minimum of work because they cannot be preempted. A typical high-level interrupt handler puts data into a circular buffer and schedule a soft interrupt by calling ddi_intr_trigger_soft- int(). The circular buffer can be protected by using a mutex that is properly initialized for the interrupt handler. The ddi_intr_get_hilevel_pri() function can be used before calling ddi_intr_add_handler() to help determine which type of interrupt handler can be used. Most device drivers are designed with the knowledge that supported devices always generate low level interrupts. On some machines, however, interrupts are high-level above the scheduler level and on other machines they are not. Devices such as those those using SBus interrupts or VME bus level 6 or 7 interrupts must use the ddi_intr_get_hilevel_pri() function to test the type of interrupt handler that can be used.
RETURN VALUES
The ddi_intr_get_hilevel_pri() function returns the priority value for a high-level interrupt.
CONTEXT
The ddi_intr_get_hilevel_pri() function can be called from either user or kernel non-interrupt context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), ddi_intr_add_handler(9F), ddi_intr_alloc(9F), ddi_intr_enable(9F), ddi_intr_get_pri(9F), ddi_intr_trigger_softint(9F), mutex(9F) Writing Device Drivers SunOS 5.11 07 Apr 2005 ddi_intr_get_hilevel_pri(9F)
Related Man Pages
ddi_intr_hilevel(9f) - opensolaris
ddi_intr_get_hilevel_pri(9f) - sunos
ddi_intr_get_softint_pri(9f) - sunos
ddi_intr_remove_softint(9f) - sunos
ddi_intr_remove_softint(9f) - opensolaris
Similar Topics in the Unix Linux Community
Signalling interrupts to user space
Interupt Context Switching