opensolaris man page for ddi_get_pid

Query: ddi_get_pid

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_get_pid(9F) 					   Kernel Functions for Drivers 					   ddi_get_pid(9F)

NAME
ddi_get_pid - returns the process ID
SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> #include <sys/sunddi.h> pid_t ddi_get_pid(void);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
ddi_get_pid() obtains the process ID of the current process. This value can be used to allow only a select process to perform a certain operation. It can also be used to determine whether a device context belongs to the current process.
RETURN VALUES
ddi_get_pid() returns the process ID.
CONTEXT
This routine can be called from user context only.
SEE ALSO
drv_getparm(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 18 Feb 1998 ddi_get_pid(9F)
Related Man Pages
proc_ref(9f) - opensolaris
proc_unref(9f) - opensolaris
drv_getparm(9f) - centos
drv_getparm(9f) - linux
drv_getparm(9f) - hpux
Similar Topics in the Unix Linux Community
Trying to block signal
solaris zones vs container..
PHP Man Pages Now Available (Over 10,000)
%memused is high
Solaris 10 - password complexity not working