opensolaris man page for ddi_get_lbolt

Query: ddi_get_lbolt

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_get_lbolt(9F)					   Kernel Functions for Drivers 					 ddi_get_lbolt(9F)

NAME
ddi_get_lbolt - returns the value of lbolt
SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> #include <sys/sunddi.h> clock_t ddi_get_lbolt(void);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
ddi_get_lbolt() returns the value of lbolt where lbolt is an integer that represents the number of clock ticks since the last system reboot. This value is used as a counter or timer inside the system kernel. The tick frequency can be determined by using drv_usectohz(9F) which converts microseconds into clock ticks.
RETURN VALUES
ddi_get_lbolt() returns the value of lbolt.
CONTEXT
This routine can be called from any context.
SEE ALSO
ddi_get_time(9F), drv_getparm(9F), drv_usectohz(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 18 Feb 1998 ddi_get_lbolt(9F)
Related Man Pages
drv_getparm(9f) - opensolaris
drv_hztousec(9f) - redhat
drv_hztousec(9f) - debian
drv_hztousec(9f) - v7
drv_hztousec(9f) - minix
Similar Topics in the Unix Linux Community
solaris zones vs container..
PHP Man Pages Now Available (Over 10,000)
Identify problem with while getopts
%memused is high
Shopt -s histappend