Query: ddi_enter_critical
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
ddi_enter_critical(9F) Kernel Functions for Drivers ddi_enter_critical(9F)NAMEddi_enter_critical, ddi_exit_critical - enter and exit a critical region of controlSYNOPSIS#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> unsigned int ddi_enter_critical(void); void ddi_exit_critical(unsignedint ddic);INTERFACE LEVELSolaris DDI specific (Solaris DDI).PARAMETERSddic The returned value from the call to ddi_enter_critical() must be passed to ddi_exit_critical().DESCRIPTIONNearly all driver operations can be done without any special synchronization and protection mechanisms beyond those provided by, for exam- ple, mutexes (see mutex(9F)). However, for certain devices there can exist a very short critical region of code which must be allowed to run uninterrupted. The function ddi_enter_critical() provides a mechanism by which a driver can ask the system to guarantee to the best of its ability that the current thread of execution will neither be preempted nor interrupted. This stays in effect until a bracketing call to ddi_exit_critical() is made (with an argument which was the returned value from ddi_enter_critical()). The driver may not call any functions external to itself in between the time it calls ddi_enter_critical() and the time it calls ddi_exit_critical().RETURN VALUESThe ddi_enter_critical() function returns an opaque unsigned integer which must be used in the subsequent call to ddi_exit_critical().CONTEXTThis function can be called from user, interrupt, or kernel context.WARNINGSDriver writers should note that in a multiple processor system this function does not temporarily suspend other processors from executing. This function also cannot guarantee to actually block the hardware from doing such things as interrupt acknowledge cycles. What it can do is guarantee that the currently executing thread will not be preempted. Do not write code bracketed by ddi_enter_critical() and ddi_exit_critical() that can get caught in an infinite loop, as the machine may crash if you do.SEE ALSOmutex(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_enter_critical(9F)
Similar Topics in the Unix Linux Community |
---|
What does this mean? |
Grep the 'not running' jobs and will send the update in mail with its name(job) |
%memused is high |
What is good? |
Shopt -s histappend |