opensolaris man page for ddi_dma_unbind_handle

Query: ddi_dma_unbind_handle

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_dma_unbind_handle(9F)				   Kernel Functions for Drivers 				 ddi_dma_unbind_handle(9F)

NAME
ddi_dma_unbind_handle - unbinds the address in a DMA handle
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_unbind_handle(ddi_dma_handle_t handle);
PARAMETERS
handle The DMA handle previously allocated by a call to ddi_dma_alloc_handle(9F).
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
ddi_dma_unbind_handle() frees all DMA resources associated with an existing DMA handle. When a DMA transfer completes, the driver should call ddi_dma_unbind_handle() to free system DMA resources established by a call to ddi_dma_buf_bind_handle(9F) or ddi_dma_addr_bind_handle(9F). ddi_dma_unbind_handle() does an implicit ddi_dma_sync(9F) making further synchronization steps unnecessary.
RETURN VALUES
DDI_SUCCESS on success DDI_FAILURE on failure
CONTEXT
ddi_dma_unbind_handle() can be called from user, kernel, or interrupt context.
SEE ALSO
ddi_dma_addr_bind_handle(9F), ddi_dma_alloc_handle(9F), ddi_dma_buf_bind_handle(9F), ddi_dma_free_handle(9F), ddi_dma_sync(9F) Writing Device Drivers SunOS 5.11 26 Sep 1994 ddi_dma_unbind_handle(9F)
Related Man Pages
ddi_dma_free_handle(9f) - opensolaris
ddi_dma_unbind_handle(9f) - opensolaris
ddi_dma_unbind_handle(9f) - suse
ddi_dma_unbind_handle(9f) - php
ddi_dma_unbind_handle(9f) - mojave
Similar Topics in the Unix Linux Community
DMA overrun&amp; underrun
DMA failure ?