opensolaris man page for ddi_dev_nregs

Query: ddi_dev_nregs

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_dev_nregs(9F)					   Kernel Functions for Drivers 					 ddi_dev_nregs(9F)

NAME
ddi_dev_nregs - return the number of register sets a device has
SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_nregs(dev_info_t *dip, int *resultp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
dip A pointer to the device's dev_info structure. resultp Pointer to an integer that holds the number of register sets on return.
DESCRIPTION
The ddi_dev_nregs() function returns the number of sets of registers the device has.
RETURN VALUES
The ddi_dev_nregs() function returns: DDI_SUCCESS A successful return. The number of register sets is returned in resultp. DDI_FAILURE The device has no registers.
CONTEXT
The ddi_dev_nregs() function can be called from user, interrupt, or kernel context.
SEE ALSO
ddi_dev_nintrs(9F), ddi_dev_regsize(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_dev_nregs(9F)
Related Man Pages
ddi_dev_is_sid(9f) - sunos
ddi_dev_nintrs(9f) - opensolaris
ddi_dev_is_sid(9f) - php
ddi_dev_is_sid(9f) - minix
ddi_dev_is_sid(9f) - redhat
Similar Topics in the Unix Linux Community
Trying to block signal
Change directory for core file
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
Identify problem with while getopts
Shopt -s histappend