opensolaris man page for csx_resetfunction

Query: csx_resetfunction

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

csx_ResetFunction(9F)					   Kernel Functions for Drivers 				     csx_ResetFunction(9F)

NAME
csx_ResetFunction - reset a function on a PC card
SYNOPSIS
#include <sys/pccard.h> int32_t csx_ResetFunction(client_handle_t ch, reset_function_t *rf);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). rf Pointer to a reset_function_t structure.
DESCRIPTION
csx_ResetFunction() requests that the specified function on the PC card initiate a reset operation.
STRUCTURE MEMBERS
The structure members of reset_function_t are: uint32_t Socket; /* socket number */ uint32_t Attributes; /* reset attributes */ The fields are defined as follows: Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. Attributes Must be 0.
RETURN VALUES
CS_SUCCESS Card Services has noted the reset request. CS_IN_USE This Card Services implementation does not permit configured cards to be reset. CS_BAD_HANDLE Client handle is invalid. CS_NO_CARD No PC card in socket. CS_BAD_SOCKET Specified socket or function number is invalid. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.
CONTEXT
This function may be called from user or kernel context.
SEE ALSO
csx_event_handler(9E), csx_RegisterClient(9F) PC Card 95 Standard, PCMCIA/JEIDA
NOTES
csx_ResetFunction() has not been implemented in this release and always returns CS_IN_USE. SunOS 5.11 19 Jul 1996 csx_ResetFunction(9F)
Related Man Pages
csx_accessconfigurationregister(9f) - sunos
csx_releasesocketmask(9f) - sunos
csx_accessconfigurationregister(9f) - opensolaris
csx_releaseconfiguration(9f) - opensolaris
csx_resetfunction(9f) - opensolaris
Similar Topics in the Unix Linux Community
df command on Linux and Solaris
Socket implementation differences
How to know my graphic card type
Sutekh 0.6.0 (Stable branch)
Nic Card for SunBlade 1500 Tower