opensolaris man page for canput

Query: canput

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

canput(9F)						   Kernel Functions for Drivers 						canput(9F)

NAME
canput - test for room in a message queue
SYNOPSIS
#include <sys/stream.h> int canput(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the message queue.
DESCRIPTION
canput() searches through the stream (starting at q) until it finds a queue containing a service routine where the message can be enqueued, or until it reaches the end of the stream. If found, the queue containing the service routine is tested to see if there is room for a mes- sage in the queue. canputnext(q) and bcanputnext(q, pri) should always be used in preference to canput(q->q_next) and bcanput(q->q_next, pri) respectively.
RETURN VALUES
1 If the message queue is not full. 0 If the queue is full.
CONTEXT
canput() can be called from user or interrupt context.
SEE ALSO
bcanput(9F), bcanputnext(9F), canputnext(9F), putbq(9F), putnext(9F) Writing Device Drivers STREAMS Programming Guide
WARNINGS
Drivers are responsible for both testing a queue with canput() and refraining from placing a message on the queue if canput() fails. SunOS 5.11 11 Apr 1991 canput(9F)
Related Man Pages
canput(9f) - opensolaris
canput(9f) - debian
canput(9f) - centos
canput(9f) - opendarwin
canput(9f) - linux
Similar Topics in the Unix Linux Community
Drivers' The NZ Herald Watch service style
Permission denied when creating message queue