opensolaris man page for btopr

Query: btopr

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

btopr(9F)						   Kernel Functions for Drivers 						 btopr(9F)

NAME
btopr - convert size in bytes to size in pages (round up)
SYNOPSIS
#include <sys/ddi.h> unsigned long btopr(unsigned long numbytes);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
numbytes Number of bytes.
DESCRIPTION
The btopr() function returns the number of memory pages contained in the specified number of bytes memory, rounded up to the next whole page. For example, if the page size is 2048, then btopr(4096) returns 2, and btopr(4097) returns 3.
RETURN VALUES
The return value is always the number of pages. There are no invalid input values, and therefore no error return values.
CONTEXT
The btopr() function can be called from user, interrupt, or kernel context.
SEE ALSO
btop(9F), ddi_btopr(9F), ptob(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 btopr(9F)
Related Man Pages
ddi_btop(9f) - opensolaris
ddi_ptob(9f) - opensolaris
btop(9f) - sunos
ddi_btopr(9f) - sunos
ptob(9f) - linux
Similar Topics in the Unix Linux Community
What does this mean?
Study UNIX Kernel
What's legal and what's not?
What is good?
Shopt -s histappend