opensolaris man page for atomic_set_long_excl

Query: atomic_set_long_excl

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

atomic_bits(9F) 					   Kernel Functions for Drivers 					   atomic_bits(9F)

NAME
atomic_bits, atomic_set_long_excl, atomic_clear_long_excl - atomic set and clear bit operations
SYNOPSIS
#include <sys/atomic.h> int atomic_set_long_excl(volatile ulong_t *target, uint_t bit); int atomic_clear_long_excl(volatile ulong_t *target, uint_t bit);
DESCRIPTION
The atomic_set_long_excl() and atomic_clear_long_excl() functions perform an exclusive atomic bit set or clear operation on target. The value of bit specifies the number of the bit to be modified within target. Bits are numbered from zero to one less than the maximum number of bits in a long. If the value of bit falls outside of this range, the result of the operation is undefined.
RETURN VALUES
The atomic_set_long_excl() and atomic_clear_long_excl() functions return 0 if bit was successfully set or cleared. They return -1 if bit was already set or cleared.
ERRORS
No errors are defined.
CONTEXT
These functions can be called from user, interrupt, or kernel context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+
SEE ALSO
atomic_add(9F), atomic_and(9F), atomic_cas(9F), atomic_dec(9F), atomic_inc(9F), atomic_or(9F), atomic_swap(9F), membar_ops(9F), attributes(5), atomic_ops(3C) SunOS 5.11 16 Jan 2006 atomic_bits(9F)
Related Man Pages
atomic_and_16(9f) - opensolaris
atomic_and(9f) - opensolaris
atomic_swap_16(9f) - opensolaris
atomic_swap_uchar(9f) - opensolaris
atomic_swap_ulong(9f) - opensolaris
Similar Topics in the Unix Linux Community
Compiling 32 bit app on 64 bit kernal
c program to set the m-bit to n-bit