opendarwin man page for store

Query: store

OS: opendarwin

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

STORE(9)						   BSD Kernel Developer's Manual						  STORE(9)

NAME
store, subyte, susword, suswintr, suword -- store data to user-space
SYNOPSIS
#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> #include <sys/resourcevar.h> int subyte(void *base, int byte); int susword(void *base, int word); int suswintr(void *base, int word); int suword(void *base, long word);
DESCRIPTION
The store functions are designed to copy small amounts of data to user-space. The store routines provide the following functionality: subyte() Stores a byte of data to the user-space address base. susword() Stores a short word of data to the user-space address base. suswintr() Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context. suword() Stores a word of data to the user-space address base.
RETURN VALUES
The store functions return 0 on success or -1 on failure.
SEE ALSO
copy(9), fetch(9)
BSD
January 7, 1996 BSD
Related Man Pages
store(9) - mojave
store(9) - debian
suword(9) - debian
suword16(9) - debian
suswintr(9) - freebsd
Similar Topics in the Unix Linux Community
bash Script: Issue with iterating Directory and store into array
Run stored procedure from shell script
Ufsrestore
Restore .dmg containing multiple partitions to bootable USB flash drive
How to store the passwords securely and use in scripts?