netbsd man page for yield

Query: yield

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PREEMPT(9)						   BSD Kernel Developer's Manual						PREEMPT(9)

NAME
preempt, yield -- general preempt and yield functions
SYNOPSIS
#include <sys/sched.h> void preempt(void); #include <sys/proc.h> void yield(void);
DESCRIPTION
The preempt() function puts the current LWP back on the system run queue and performs an involuntary context switch. The yield() function is mostly same as preempt(), except that it performs a voluntary context switch. These functions drop the kernel lock before switching and re-acquire it before returning.
BSD
July 3, 2007 BSD
Related Man Pages
critical_exit(9) - freebsd
cpu_need_resched(9) - netbsd
timeslice(5) - hpux
critical_enter(9) - linux
critical(9) - mojave
Similar Topics in the Unix Linux Community
Puzzle: file name grepped from text file yields &quot;no such file&quot;
exec perl in expect script yields &quot;invalid command&quot;
UNIX.com links from Google yield invalid thread error
awk output yields error: awk:can't open job_name (Autosys)
Simple conditional yields too many responses