Query: sysmon_task_queue_fini
OS: netbsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
SYSMON_TASKQ(9) BSD Kernel Developer's Manual SYSMON_TASKQ(9)NAMEsysmon_taskq -- general purpose system monitoring task queueSYNOPSIS#include <dev/sysmon/sysmon_taskq.h> void sysmon_task_queue_preinit(void); void sysmon_task_queue_init(void); void sysmon_task_queue_fini(void); int sysmon_task_queue_sched(u_int pri, void (*func)(void *), void *arg);DESCRIPTIONThe machine-independent sysmon_taskq provides a simple general purpose task queue. It can be used to run callbacks that require thread con- text, but do not warrant the use of a more fine-grained solution. Although the intended usage is related to the context of system monitoring and power management, also other comparable functions are suitable for sysmon_taskq.FUNCTIONSThe necessary internal data structures are initialized during system startup by sysmon_task_queue_preinit(). Before actual usage, a machine- dependent procedure should finish the initialization by calling sysmon_task_queue_init(). This will create a kernel thread that can be later halted by sysmon_task_queue_fini(). All scheduled tasks are executed before the queue is halted. The sysmon_task_queue_sched() enqueues func to be executed at the priority pri. If pri is 0, the scheduled function will be placed as the last element in the queue. The single argument passed to func is specified by arg.RETURN VALUESUpon successful completion, sysmon_task_queue_sched() returns 0. Otherwise, the following error values are returned: [EINVAL] An invalid parameter was specified. [ENOMEM] There was not enough memory.SEE ALSOqueue(3), kthread(9), workqueue(9)AUTHORSJason R. Thorpe <thorpej@NetBSD.org>BSDJanuary 24, 2010 BSD
Related Man Pages |
---|
sysmon_task_queue_preinit(9) - netbsd |
sysmon_task_queue_fini(9) - netbsd |
sysmon_task_queue_sched(9) - netbsd |
ddi_taskq_dispatch(9f) - opensolaris |
taskq(9f) - opensolaris |
Similar Topics in the Unix Linux Community |
---|
Looking for a general purpose System Monitor |
print queue monitoring |
Need help going from power pc to newer computer! |
How to send alerts to the sysmon facility? |