netbsd man page for setbit

Query: setbit

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

SETBIT(9)						   BSD Kernel Developer's Manual						 SETBIT(9)

NAME
setbit -- macros related to bitmaps
SYNOPSIS
#include <sys/param.h> void setbit(array, x); void clrbit(array, x); int isset(array, x); int isclr(array, x);
DESCRIPTION
The setbit family of macros operate with bitmaps, also known as bit arrays. In a nutshell, setbit() sets the bit x in array, clrbit() clears it, isset() tests whether x is set, and isclr() returns 1 if x is not set.
EXAMPLES
The following example declares a buffer of 10 chars, treating it as an array of 80 bits: char buf[10]; ... setbit(buf, 12); /* set the fifth bit in the second byte */
SEE ALSO
bitstring(3)
CAVEATS
The number of valid bits in a given array is assumed to be multiple of CHAR_BIT, the number of bits for smallest object that is not a bit- field.
BSD
March 1, 2010 BSD
Related Man Pages
bit_ffc(3) - freebsd
bit_decl(3) - freebsd
bit_test(3) - freebsd
bit_nset(3) - freebsd
bit_nclear(3) - freebsd
Similar Topics in the Unix Linux Community
How to install PGX32 on Sparc 10 Ultra?
Vm versus physical linux server
Grandpa returning to UNIX
Grep command to show the number of results