Query: putiobuf
OS: netbsd
Section: 9
Links: netbsd man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
GETIOBUF(9) BSD Kernel Developer's Manual GETIOBUF(9)NAMEgetiobuf, putiobuf -- I/O descriptor allocation interfaceSYNOPSIS#include <sys/buf.h> struct buf * getiobuf(struct vnode *vp, bool waitok); void putiobuf(struct buf *bp);DESCRIPTIONgetiobuf() allocates a buf structure. vp The vnode to which the allocated buffer will be associated. This can be NULL. waitok If true, getiobuf can sleep until enough memory is available. Otherwise, it returns NULL immediately if not enough memory is avail- able. Note that the allocated buffer doesn't belong to the buffer cache. To free it, putiobuf() should be used. brelse() should not be used on it. putiobuf() frees bp, which should be a buffer allocated with getiobuf().SEE ALSObuffercache(9), intro(9)BSDMay 6, 2008 BSD
Related Man Pages |
---|
brelse(9) - netbsd |
getblk(9) - netbsd |
vop_vptocnp(9) - centos |
vop_vptocnp(9) - minix |
vop_vptocnp(9) - redhat |
Similar Topics in the Unix Linux Community |
---|
Unix File Permissions |
Memory Leaks |
NetBSD 6.1.2: apm and admd not found |