netbsd man page for putiobuf

Query: putiobuf

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

GETIOBUF(9)						   BSD Kernel Developer's Manual					       GETIOBUF(9)

NAME
getiobuf, putiobuf -- I/O descriptor allocation interface
SYNOPSIS
#include <sys/buf.h> struct buf * getiobuf(struct vnode *vp, bool waitok); void putiobuf(struct buf *bp);
DESCRIPTION
getiobuf() allocates a buf structure. vp The vnode to which the allocated buffer will be associated. This can be NULL. waitok If true, getiobuf can sleep until enough memory is available. Otherwise, it returns NULL immediately if not enough memory is avail- able. Note that the allocated buffer doesn't belong to the buffer cache. To free it, putiobuf() should be used. brelse() should not be used on it. putiobuf() frees bp, which should be a buffer allocated with getiobuf().
SEE ALSO
buffercache(9), intro(9)
BSD
May 6, 2008 BSD
Related Man Pages
brelse(9) - netbsd
vop_vptocnp(9) - debian
vop_vptocnp(9) - minix
vop_vptocnp(9) - suse
vop_vptocnp(9) - hpux
Similar Topics in the Unix Linux Community
Memory Leaks
Better to Use Return Code or wc -l Output?
Vm versus physical linux server
Grandpa returning to UNIX
Grep command to show the number of results