netbsd man page for proc_find

Query: proc_find

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PROC_FIND(9)						   BSD Kernel Developer's Manual					      PROC_FIND(9)

NAME
proc_find, pgrp_find -- find process or process group
SYNOPSIS
#include <sys/proc.h> struct proc * proc_find(pid_t pid); struct pgrp * pgrp_find(pid_t pgid); extern kmutex_t *proc_lock;
DESCRIPTION
The proc_find() and pgrp_find() functions retrieve process and process group structures from process ID pid and process group ID pgid. Both functions must be called by holding a mutex(9) on proc_lock.
RETURN VALUES
Upon successful completion, the described functions return a pointer to either struct proc or struct pgrp. Otherwise, if the requested ID was not found, NULL is returned.
SEE ALSO
curproc(9)
BSD
July 1, 2010 BSD
Related Man Pages
gsignal(9) - debian
pgsignal(9) - debian
setpgrp(2) - freebsd
pgsignal(9) - hpux
pgsignal(9) - osx
Similar Topics in the Unix Linux Community
script to ftp recent changed files
TCL script to capture range of lines and create two independent variables