netbsd man page for preempt

Query: preempt

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PREEMPT(9)						   BSD Kernel Developer's Manual						PREEMPT(9)

NAME
preempt, yield -- general preempt and yield functions
SYNOPSIS
#include <sys/sched.h> void preempt(void); #include <sys/proc.h> void yield(void);
DESCRIPTION
The preempt() function puts the current LWP back on the system run queue and performs an involuntary context switch. The yield() function is mostly same as preempt(), except that it performs a voluntary context switch. These functions drop the kernel lock before switching and re-acquire it before returning.
BSD
July 3, 2007 BSD
Related Man Pages
critical(9) - debian
cpu_need_resched(9) - netbsd
cpu_switchto(9) - netbsd
userret(9) - netbsd
critical_enter(9) - linux
Similar Topics in the Unix Linux Community
Effect of Preemptive Kernel
Blocked process and preempt
Can someone describe the process of pre-emption in UNIX?