netbsd man page for pmatch

Query: pmatch

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PMATCH(9)						   BSD Kernel Developer's Manual						 PMATCH(9)

NAME
pmatch -- performs pattern matching on strings
SYNOPSIS
#include <sys/systm.h> int pmatch(const char *string, const char *pattern, const char **estr);
DESCRIPTION
Extract substring matching pattern from string. If not NULL, estr points to the end of the longest exact or substring match. pmatch() uses the following metacharacters: ? match any single character. * match any character 0 or more times. [ define a range of characters that will match. The range is defined by 2 characters separated by a '-'. The range definition has to end with a ']'. A '^' following the '[' will negate the range.
RETURN VALUES
pmatch() will return 2 for an exact match, 1 for a substring match, 0 for no match and -1 if an error occurs.
BSD
October 12, 2003 BSD
Related Man Pages
regcomp(3) - linux
regex(3) - linux
regerror(3) - linux
regfree(3) - linux
regexec(3) - suse
Similar Topics in the Unix Linux Community
Using NIS-ypmatch, ypcat, Lname, Gname to get username/key
ypmatch,ypcat,NIS
Shell scripts exits after executing ypmatch
Ypmatch