netbsd man page for pgrp_find

Query: pgrp_find

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

PROC_FIND(9)						   BSD Kernel Developer's Manual					      PROC_FIND(9)

NAME
proc_find, pgrp_find -- find process or process group
SYNOPSIS
#include <sys/proc.h> struct proc * proc_find(pid_t pid); struct pgrp * pgrp_find(pid_t pgid); extern kmutex_t *proc_lock;
DESCRIPTION
The proc_find() and pgrp_find() functions retrieve process and process group structures from process ID pid and process group ID pgid. Both functions must be called by holding a mutex(9) on proc_lock.
RETURN VALUES
Upon successful completion, the described functions return a pointer to either struct proc or struct pgrp. Otherwise, if the requested ID was not found, NULL is returned.
SEE ALSO
curproc(9)
BSD
July 1, 2010 BSD
Related Man Pages
setpgid(2) - opensolaris
gsignal(9) - debian
setpgid(2) - sunos
setpgid(2) - freebsd
pgsignal(9) - hpux
Similar Topics in the Unix Linux Community
Unix File Permissions
How to install PGX32 on Sparc 10 Ultra?
Make bold chars in UNIX
BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD